Duke Nukem 3D Atomic

This topic contains 8 replies, has 4 voices, and was last updated by admin admin 2 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5890
    admin
    admin
    Keymaster

    Hi People,

    I created this layout for people who like to play Duke3D on touchscreen. I created icons quickly with Magic Icons Designer (if you like my work, you can support me and send ideas for new icons :D). This is attempt to play Duke3D like a modern shooter on touchscreen.

    Requirements :

    • Duke Nukem Atomic version
    • Magic Dosbox v63+ (in the time of writing this is out version 62)

    History:

    • version 1 – initial layout
    • version 2 – added support for inventory

    Layout
    DukeNukem3D mgc file

    SETUP
    Run SETUP.EXE and “Sound Setup” should be :

    • Current Sound FX Card (Sound Blaster)
    • Current Music Card (Sound Blaster)
    • Sound FX Volume [220]
    • Music Volume [220]

    Controller Setup should be : Controller Setup->Choose Controller Type->Keyboard and Mouse
    Setup Mouse should be :
    Single Clicked Mouse Buttons:

    • Left Button (Fire)
    • Middle Button – does not matter what you set here
    • Right Button – Mouse_Aiming

    In Mouse Aiming Mode set momentary button and enable “Invert Mouse Aiming up and down”

    How to use it

    Main idea is : Finger on left hand controls joystick (forward/backward/strafe). Finger on right hand controls turning to left/right with relative mouse and buttons for fire etc. Mouse sensitivity can be adjusted on several places – in duke options and in magic dosbox as well.

    Screenshot_01

    Layout starts like is seen on picture above. One-two seconds runs two automatic macros which sets “mouse aim” button(10) and “run” button(2). After this action they will be disabled. During gameplay enable “mouse aim”. Disable mouse aim when in menu, else menu wont react (because I set mouse aim to right mouse button). Disable/enable run by your needs. Remember, loading states can breaks these buttons states. In mouse option is disabled mouse clicking, it only does movement (due unwanted fire). If you experience strange behaviors try re-push buttons for aim and run.

    Screenshot_01

    Screenshot_01

    • 1 – Fire – Enabled flag “Non Blocking” which allows fire and aim at once
    • 2 – Run – Enable/Disable togger
    • 3 – Use/Open/Manipulate
    • 4 – Kick
    • 5 – Jump
    • 6 – Next/Previous weapon
    • 7 – Crouch
    • 8 – Joystick, strafe left/right, move forward/backward
    • 9 – Secondary fire. Sometimes I need precise aim and fire (with rpg)
    • 10 – Enable/Disable mouse aim
    • 11 – Pause/Play game
    • 12 – Map/Jetpack/Night vision
    • 13 – Menu – save/load states

    Screenshot_01

    Tips at the end

    • Play at 320×200, it is fast
    • If you need better performance use always Sound Blaster 2.0 in setup
    • If you need yet more performance, you must use expert settings and set cycles=max 120%. In this case I recommend scroll down to “Main Program”. On right side is button “GET”. Here generate all to clipboard. Now open expert settings and replace old content with newly generated config in clipboard
    #5892

    Larrynho
    Participant

    Tested !

    So far so good ! It works very good on the MDB beta build, its so much more confortable than my own design without mouse aiming. Definetly a step in the right direction. Tested in duke 3d and tweaked it for blood ( same engine ) and works quite nice too.

    Next step: add the option in the virtual dpad to have combined keypresses for 1 direction (up+left, up+right, dow+left, down+right )… thats the final step I think to make the controls perfect.

    Love this, mad props dev 😀

    edit: ok forguet about the diagonal thing… its toggleable in the dpad options XD Contros are a-ok. LOVE EM.

    #5924
    zebumper
    zebumper
    Participant

    Seems to be a very great job !!!

    #6098
    Liger
    Liger
    Participant

    It works great, except he doesn’t move when I move the joystick. How can I move? Thanks.

    #6099
    admin
    admin
    Keymaster

    Hi, It’s all about setup. I set movement to keyboard arrows. You can check it if you enter design mode and press twice at joystick. Scroll down and you should see arrows. If you can’t move then run SETUP.EXE and follow instructions posted in main post about SETUP.EXE and check controller options. There should be arrows for keyboard.

    #6100
    Liger
    Liger
    Participant

    Thanks. Turns out, the controls were set to modern (wasd to move, e to enter, space to jump, etc), hence why I had issues. All is well now. Now if I could get my gamepad to work, that’d be even better!

    #6101
    admin
    admin
    Keymaster

    You can get it work, mDosbox supports it. On my youtube channel is video guide, for other games, but it surely help

    #6102
    Liger
    Liger
    Participant

    Link to your YT channel, please? Also, good looking out and I appreciate your help.

    #6103
    admin
    admin
    Keymaster

    Link to youtube guides is in main menu 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.