The Update Intended to fix controls Nov.19 has ruined mine

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
  • #5300

    I can no longer map my analogs on my ps4 controller to anything other than directional movement . it indicates it excepted change but it doesn’t is there anyway to downgrade? This has broken functionality in every game I have they are not playable without the ability to map the analogs. I had no issues at all prior to today’s update. I seriously hope this update isn’t forcing us to assign the analogs as mouse and gamepad because the calibration is terrible on both the gamepad only supports 2 axis and 2 button and auto returns itself to dead center making it not only grossly insufficient but also rediculously awkward.


    Please could you post your messages without all that not necessary blaming around and double posts? Anyway thank you for report. Will check it at home as soon as possible.


    Please post steps to reproduce. What are you trying to do. Which version of magic dosbox you use (free or full)?


    Tested both versions, free and donated. I did not find anything wrong. I bound keyboard keys to both left and right analog sticks and everything works like is expected.

    Please provide more information, else this post will be closed.


    I use the paid version . the issue I’m experiencing is my analog controls no longer allow any mapping other than directional movement when mapped as keyboard regardless of what I map them too. Both sticks do this . I noticed the issue last night about 6 pm PST. I don’t know how to logcat this issue because magic dosbox allows for remap, accepts remap but fails to remap. Both sticks are stuck with up,down,left,right as map regardless what I set them too .(i.e if I map them to y,z,x,c the app claims it accepts changes but the sticks remain mapped up,down,left,right) I am stuck using the keymapper built into sixaxis controller that works but lacks all the F keys and Ctrl (didn’t realize how often these are used til you lack them) and in order to get sixaxis controller to work it has to be set to input device which negates the keyboard (only 1 keyboard can be active at a time, sixaxis has to take the place of the built in one in order to get the app to recognize it ) Inever had control issues prior and the only thing that’s changed (globally) is an auto-update (yeah kicking myself for not killing that) to your app my phone took at 5pm PST. I checked out the changelog and it said it was an update intended to fix control functionality so I contacted you. I’m sure I’m not your only issue (play store rating went from 4.8 to 4.4, in order to affect that at all would take a considerable number of complaints)for what its worth I didn’t complain via google play I came here.


    Could not be updated any other application, which runs in background and can affect your gamepad functionality?

    Allright. I don’t say that you are not talking truth. On google play was written very similar message to yours (include title), so I think it was you. Google play rating is unchanged, you made a mistake, you looked at rating of free version which is really 4.4.

    Your message is very hardly readable, but I understand that you use analog sticks – left and right. And you try bind keyboard keys to analog sticks. Right?

    Please could you record video of these steps ?

    1. Create new game profile
    2. start magic dosbox to black console
    3. open advanced settings – I need see which version you have, close it and continue to next step
    4. open mapper and bind keyboard keys A, B, C, D to left analog stick. Confirm all.
    5. move analog stick UP, DOWN, LEFT, RIGHT

    Please post video link here. At beginning check that your gamepad is connected.


    Edit: Ive been playing around with the controls and I’ve discovered that it seems the controls setup wants my triggers to be be gas, brake. I can get other keys to assign to my analogs now except forward and reverse. These always revert back to directional. I do not want to adjust the in game controls setup given how long it took to come up with a feasible control scheme (mechwarrior is control intensive easily over 40 controls, to map this to a PS 4 controller is very difficult it would not work if I had to use the triggers as gas brake, I cannot omit controls and nothing other than gas brake can be mapped to up down and be usable) I’m kind of stuck . is there any way to just go back an update? I don’t know maybe release the old version via this site til a proper fix worked out?


    Yes, I could map as controller, but the controller is terrible as far as calibration goes . I’ve got it set to none in config. Are you suggesting I map as a controller but just omit the actual stick and just map buttons? If so, I hadn’t considered that, but whenever I map a controller the games want me to calibrate it , how could I do this without the stick? Hmmm I guess I could map as stick, calibrate, then remap as buttons. I can’t help but note that your update requires a lot of concessions on my part. I will not be allowing your app to auto update any longer do to this inconveince.


    Yes, of course you can block updates. I asked you for some things and I still did not get them. Sorry, I cant help. Will try another device with another gamepad. But I am sure at 99% that fault is not on magic dosbox side.

    Please try write less with more information


    I just tested Duke3D with another gamepad. I tried phone+ipega controller. Everything works fine. Before I tested Nvidia shield portable without issues…Will ask for test some friends.


    try mapping somthing nonnn directionnal to them . It simply will not work . And how is duke nukem applicable ? The forward key is forward in that game.


    what specifically was the update for? Im wondering if it had anything to do with xboxone controller in the forum . im using a ps4 controller that had no issues til someone complained there triggers dont work on an xboxone controller and your insisting your controller works . im thinking this is just way too coincidental . the Controller keylayout on a ps4 controller is different then that of any other sixaxis controller and your insistence that you just tried an ipega (not familiar with those but im guessing it uses the generic abxy setup ?) makes me wonder if somthing got changed that improved functionality in one device but had the opposite effect on mine . I have tried everything from remapping all controls in both game and app and cannot get the analogs to do except anything otyer than up down left right when mapping as keyboard and also fails when trying to map gamepad keys to analogs. I had my right stick mapped as up (=)
    Down (-)
    Left (,)
    Right (.)
    last night even though these keys are still mapped the only things my analogs do is up down left right. i beleive you when you say they are working on your ipega though im not certain you mapped anything other than up down left right but regardless the point is i beleive you. I would not waste this kind of time on this if i hadnt already had them mapped and know for a fact that my map layout was working prior til i got off work last night. I have ruled out any other potential system app or user app updates. The only thing that changed was this app got an update.Is it possible to get an early version of the app ? It seems like that would be the easiest fix .


    Ok i got one more idea. I will dig out a usb otg converter.I will hard wire the ps4 controller remap everything and if that works i have no idea what it proves. I know sixaxis controller isnt blocking it because it is the only way to make it accept keymappings currently . I will disregard all of that. I will disregard how lame it is to hardwire a bluetooth controller is particularly this one because it draws power from the phone battery when hardwired. I really dont want to but will because i know it worked the way i have it set. Im not delusional and this may seem petty to you and if so i can only assume youve never tried and succeeded at a controller layout for mechwarrior. Its litteraly took months to evolve to what it is . its not somthing you can just go a different way with or i would have.I guess it comes down to this. If this fails to give me the desired results ill try somthing else entirely.

    P.S. backing up profile saves current controller maps? Or do i duplicate and remap? Nevermind i think i just answered that question twice lol


    Sorry i just saw this post asking for a video . Im going forward with hardwiring it …..just to start with i notice the controller no longer shows up as a dualshock 4 controller on the phone it shows up as a sony wireless controller even though its wired. Ive lost the ability to remap via sixaxis controller and the buttons are no longer correctly keymapped but its detected and id have to say more responsive as far analogs go ive lost use of touchpad but wasnt using it for the game anyway the power button isnt mappable in this state it only attempts bt connection if pushed. Im going to see what happens with magic dosbox now.


    hard wiring didnt help . Once again it shows the keys as being mapped but do not map them .

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.