Dark Sun Problems

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
  • #7944
    Al ex

    Try this:

    @Echo Off
    mount c /storage/emulated/0/aGamesbacks/
    cd darksu~1

    Or simply rename the directory from “Dark Sun” to “DSUN” or something. DOS does neither like spaces in file/directory names, nor name longer than 8 characters. 🙂


    Hummm, that didn’t work for me. Which is fine for that game, I can manually type in the commands to get into the game.

    But I did manage to get Ravenloft Stone Prophet running, however, it only runs at 1.0 for the CD version. I have the patch in the folder to update it to v. 1.1, but I am not sure how to update it within Magic Dosbox. Do you know how and could you give me some instruction on how?

    Again thanks.

    I’ll check tomorrow, it’s off to bed for me 🙂

    Al ex

    Weird, must be some kind of typo. If you put the exact same commands you type to launch the game manually into the autoexec section, it has work, too. ?

    Regarding the patch: Magic Dosbox emulates a full DOS PC, so you do it just as you would on a real oldschool PC: simply launch Magic Dosbox (with expert settings, “mount c /storage/emulated/0/aGamesbacks/” in [autoexec], then go to the patch directory (“cd prophet” or whatever the directory is called), and run the patch file.


    For some reason or another, no matter what I have tried, I still can not launch Dark Sun Shattered Lands or Al Qadim via the one click method. The mount config just is not working for me for those two games. Again, I still can launch them via the command line, so it is not much of an issue there. I just think I should have shorten the folder names to make it a lot less finger tapping or typing via a keyboard, lol. Not a big issue though.

    As for the patch, I again followed the process but kept getting errors. Oddly enough, I found another copy of Stone Prophet and just converted their file type into an iso, created a cd folder within the Stone Prophet folder, then deleted all the files from that version of the game and copied over everything from GOG’s folder except their oddly named iso file. And it launches and works as the 1.10 version. So problem solved there.

    The only game that for what ever reason I can not get to work, is Ishar 3. My GOG version does not work, and I have looked around for back up copies as well, to no avail. I just get a short list of errors. It’s not important, but find it odd that just that one should be supported does not work for me no matter what I have tried.

    Anyhow, thank you again for the help.


    Al ex

    Something’s not quite right here. Ishar 3 works out of the box for me. And the autoexec section simply executes command you would otherwise type in manually.

    If you like, we can try to troubleshoot some more. It’s most likely just a typo, or a quirk in your configuration.


    Once again, I looked around for a backup of Ishar 3, and did finally manage to get it running.

    My next project is trying to get Daggerfall, with all the updates, patches and fixes running under Magic Dosbox, DaggerfallSetup-2.14.1. I also have (GOG’s setup_the_elder_scrolls_ii_daggerfall_1.07_(28043) version. I tried the one from the video tutorial, and it again for some reason didn’t work for me. But, I have found that playing around with the files a bit, or finding perhaps different versions or maybe voodoo, lol. They end up working at some point.

    I have all of my compatible Dos collection up and running in Magic Dosbox, except Arena and Daggerfall. If I can get both of those running, it will be a miracle. I need to get into the app store and give the app a 5 star review. I really do appreciate the effort and help you are offering also.

    Btw, do you guys have a discord channel? Might be easier to communicate in?

    Al ex

    No Discord, sorry. Personally, I prefer it over a classic forum. But it’s really bad for support/troubleshooting, you lose track of issues too easily.

    Anyway, you gave me a reason to finally purchase Dark Sun on GoG. Things don’t get less confusing here, because it’s working for me witbout any tweaks. Add new profile, select dsun.exe as main program, save profile, launch game. I didn’t change a single setting, and the game is running fine.
    If you’ll share your profile here, I can take a look, and try to find out what’s wrong.


    I was unable to get Daggerfall from the Official site, so I found another source, which following the video did work. I also did my best to patch it, but some patches are missing and one, I really can’t follow the instructions. It’s most experimental anyway. So it really isn’t important. More a proof of concept for that game anyway.

    As for the Dark Sun series, GOG puts them on sale from time to time, and you can pick them up for a couple of bucks. So I would wait till then.

    To get it working, I copied the config from gog’s config and copied that over to the expert config mod in Magic Dos Box:

    # language: Select another language file.
    # machine: The type of machine DOSBox tries to emulate.
    # Possible values: hercules, cga, tandy, pcjr, ega, vgaonly, svga_s3, svga_et3000, svga_et4000, svga_paradise, vesa_nolfb, vesa_oldvbe.
    # captures: Directory where things like wave, midi, screenshot get captured.
    # memsize: Amount of memory DOSBox has in megabytes.
    # This value is best left at its default to avoid problems with some games,
    # though few games might require a higher value.
    # There is generally no speed advantage when raising this value.


    # frameskip: How many frames DOSBox skips before drawing one.
    # aspect: Do aspect correction, if your output method doesn’t support scaling this can slow things down!
    # scaler: Scaler used to enlarge/enhance low resolution modes. If ‘forced’ is appended,
    # then the scaler will be used even if the result might not be desired.
    # To fit a scaler in the resolution used at full screen may require a border or side bars,
    # to fill the screen entirely, depending on your hardware, a different scaler/fullresolution might work.
    # Possible values: none, normal2x, normal3x, advmame2x, advmame3x, advinterp2x, advinterp3x, hq2x, hq3x, 2xsai, super2xsai, supereagle, tv2x, tv3x, rgb2x, rgb3x, scan2x, scan3x.


    # core: CPU Core used in emulation. auto will switch to dynamic if available and
    # appropriate.
    # Possible values: auto, dynamic, normal, simple.
    # cputype: CPU Type used in emulation. auto is the fastest choice.
    # Possible values: auto, 386, 386_slow, 486_slow, pentium_slow, 386_prefetch.
    # cycles: Amount of instructions DOSBox tries to emulate each millisecond.
    # Setting this value too high results in sound dropouts and lags.
    # Cycles can be set in 3 ways:
    # ‘auto’ tries to guess what a game needs.
    # It usually works, but can fail for certain games.
    # ‘fixed #number’ will set a fixed amount of cycles. This is what you usually
    # need if ‘auto’ fails. (Example: fixed 4000).
    # ‘max’ will allocate as much cycles as your computer is able to
    # handle.
    # Possible values: auto, fixed, max.
    # cycleup: Amount of cycles to decrease/increase with keycombos.(CTRL-F11/CTRL-F12)
    # cycledown: Setting it lower than 100 will be a percentage.

    cycles=fixed 7000

    # nosound: Enable silent mode, sound is still emulated though.
    # rate: Mixer sample rate, setting any device’s rate higher than this will probably lower their sound quality.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # blocksize: Mixer block size, larger blocks might help sound stuttering but sound will also be more lagged.
    # Possible values: 1024, 2048, 4096, 8192, 512, 256.
    # prebuffer: How many milliseconds of data to keep on top of the blocksize.


    # mpu401: Type of MPU-401 to emulate.
    # Possible values: intelligent, uart, none.
    # mididevice: Device that will receive the MIDI data from MPU-401.
    # Possible values: default, win32, alsa, oss, coreaudio, coremidi, none.
    # midiconfig: Special configuration options for the device driver. This is usually the id of the device you want to use
    # (find the id with mixer/listmidi).
    # Or in the case of coreaudio, you can specify a soundfont here.
    # See the README/Manual for more details.


    # sbtype: Type of Soundblaster to emulate. gb is Gameblaster.
    # Possible values: sb1, sb2, sbpro1, sbpro2, sb16, gb, none.
    # sbbase: The IO address of the soundblaster.
    # Possible values: 220, 240, 260, 280, 2a0, 2c0, 2e0, 300.
    # irq: The IRQ number of the soundblaster.
    # Possible values: 7, 5, 3, 9, 10, 11, 12.
    # dma: The DMA number of the soundblaster.
    # Possible values: 1, 5, 0, 3, 6, 7.
    # hdma: The High DMA number of the soundblaster.
    # Possible values: 1, 5, 0, 3, 6, 7.
    # sbmixer: Allow the soundblaster mixer to modify the DOSBox mixer.
    # oplmode: Type of OPL emulation. On ‘auto’ the mode is determined by sblaster type. All OPL modes are Adlib-compatible, except for ‘cms’.
    # Possible values: auto, cms, opl2, dualopl2, opl3, none.
    # oplemu: Provider for the OPL emulation. compat might provide better quality (see oplrate as well).
    # Possible values: default, compat, fast.
    # oplrate: Sample rate of OPL music emulation. Use 49716 for highest quality (set the mixer rate accordingly).
    # Possible values: 44100, 49716, 48000, 32000, 22050, 16000, 11025, 8000.


    # gus: Enable the Gravis Ultrasound emulation.
    # gusrate: Sample rate of Ultrasound emulation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # gusbase: The IO base address of the Gravis Ultrasound.
    # Possible values: 240, 220, 260, 280, 2a0, 2c0, 2e0, 300.
    # gusirq: The IRQ number of the Gravis Ultrasound.
    # Possible values: 5, 3, 7, 9, 10, 11, 12.
    # gusdma: The DMA channel of the Gravis Ultrasound.
    # Possible values: 3, 0, 1, 5, 6, 7.
    # ultradir: Path to Ultrasound directory. In this directory
    # there should be a MIDI directory that contains
    # the patch files for GUS playback. Patch sets used
    # with Timidity should work fine.


    # pcspeaker: Enable PC-Speaker emulation.
    # pcrate: Sample rate of the PC-Speaker sound generation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # tandy: Enable Tandy Sound System emulation. For ‘auto’, emulation is present only if machine is set to ‘tandy’.
    # Possible values: auto, on, off.
    # tandyrate: Sample rate of the Tandy 3-Voice generation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # disney: Enable Disney Sound Source emulation. (Covox Voice Master and Speech Thing compatible).


    # joysticktype: Type of joystick to emulate: auto (default), none,
    # 2axis (supports two joysticks),
    # 4axis (supports one joystick, first joystick used),
    # 4axis_2 (supports one joystick, second joystick used),
    # fcs (Thrustmaster), ch (CH Flightstick).
    # none disables joystick emulation.
    # auto chooses emulation depending on real joystick(s).
    # (Remember to reset dosbox’s mapperfile if you saved it earlier)
    # Possible values: auto, 2axis, 4axis, 4axis_2, fcs, ch, none.
    # timed: enable timed intervals for axis. Experiment with this option, if your joystick drifts (away).
    # autofire: continuously fires as long as you keep the button pressed.
    # swap34: swap the 3rd and the 4th axis. Can be useful for certain joysticks.
    # buttonwrap: enable button wrapping at the number of emulated buttons.


    # serial1: set type of device connected to com port.
    # Can be disabled, dummy, modem, nullmodem, directserial.
    # Additional parameters must be in the same line in the form of
    # parameter:value. Parameter for all types is irq (optional).
    # for directserial: realport (required), rxdelay (optional).
    # (realport:COM1 realport:ttyS0).
    # for modem: listenport (optional).
    # for nullmodem: server, rxdelay, txdelay, telnet, usedtr,
    # transparent, port, inhsocket (all optional).
    # Example: serial1=modem listenport:5000
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial2: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial3: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial4: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.


    # xms: Enable XMS support.
    # ems: Enable EMS support.
    # umb: Enable UMB support.
    # keyboardlayout: Language code of the keyboard layout (or none).


    @Echo Off
    mount c: /mnt/sdcard/

    It is the non-CD version as far as I can tell, but it works and doesn’t glitch out.


    Well, once again. With a bit of voodoo. I was able to get the fully patched version up and running on Magic Dosbox. I’ll play around with it later on to see if it is stable enough or just go with the other installation.

    As for Discord, that is fine and I can understand the reasoning behind that. I am going to search for the config layout you have for Daggerfall and give that a whirle too.

    Again, much thanks 🙂



    Heads up if you wanted to get the Dark Suns on GOG, they are having their usual large Summer Sale right now.

    Al ex

    Lol, thanks. I purchased it full price two weeks ago though. But nevermind, I like to support the CDPR group. Purchased Witcher 3 three times, too (GoG, Steam, and Switch).


    Np and cool 🙂 Also on GOG, there is a free strategy game being offered if you don’t already have it. Cheers


    Hello, long time since I have written to ask about this game. So many changes to Android since. I can not get Dark Sun Shattered Lands to run with the latest MDB; when it executes, it flashes white garb and goes back to the c prompt. Is there another config I can you could provide to get this working again?

    I’ll add this one here as well; all the Wing Commander games are playable, except Wing Commander III; for whatever reason, I can not get it set up; any suggestions?

    Both games are from GOG, and Dark Sun is the non-cd version. Wing Commander III is the cd version unless they used a DVD, and I am unaware of this.

    Thanks in advance.

    Al ex

    Mh, I just checked my GoG page, and it should indeed by the standard CD-ROM version. Onle WC4 is the DVD version, I think.
    Launch problems in any game might be related to storage access restrictions implemented by Google with the Android 12/13 updates, so it might be worth running the initial DOSBox setup again.

    Before you do so, and start moving/copying game files all over your phone, you might want to check your mountings, though. I have my game stored on an external sd card, and it’s running fine.

    The game itself as well as the DATA.DAT (the CD-ROM image file from GoG) is in a subfolder called “/Games/PC” on my external sd, which is labelled “0000-0000”. For reference, these are the contents of my expert settings section:



    cycles=max 105%




    @Echo Off
    mount c: /storage/0000-0000/Games/PC
    imgmount d /storage/0000-0000/Games/PC/WC3/DATA.DAT -t iso

Viewing 14 posts - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.