Dark Sun Problems

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #7413

    Hi, everybody. New Magic Box user here, couldn’t be happier with it except one thing.
    I can’t seem to run either Dark Sun Shattered Lands or Dark Sun Wake of the Ravager.
    Every other game, I just type the name of the exe at the prompt and it runs fine, but with the Dark Sun games, I’m having no such luck.
    They’re the GOG versions of the games and they both work fine on my laptop, so I don’t think the files themselves are the problem.
    I should be able to just type “dsun” at the prompt, but it’s not working. With Shattered Lands, it brings up this “ghostly” image that quickly fades and then it kicks me back to the prompt. With Wake of the Ravager, it just says “file not found.” Back to prompt.

    There’s also a start.exe for each game and I tried that, but it just did nothing. Straight to prompt.

    I’d sure appreciate any and all help anyone can offer. Thanks!



    In installed gog folder should be dosbox config files. They should be on same level like dosbox folder. Please find these configs and paste them here, you only need paste config which contains at the end [autoexec] section.

    Al ex

    GoG games often have tricky setups for Dosbox, so it probaly something to do with your mounting commands.
    The Ultima Underworld version for example was a pain to setup, too, because they’re using multiple .conf files at once.

    I don’t own the game myself, so I can’t test. But if you post a link to your game profile, I’ll have a look at your settings.


    Thanks for the quick response!

    I fiddled around with it last night and found a solution for Shattered Lands. I’m going to post it here in case anyone else has problems with it and they find this post. The solution is simple.

    I ran the sound_ds.exe and did the sound setup. Then I ran dsun.exe and the game worked normally. That’s it.

    As for Wake of the Ravager, I did some reading on it and it turns out the game itself has some fundamental problems unrelated to dosbox. Apparently it was really buggy at launch.
    The GOG version comes with a patch.exe.
    I tried running the patch and the sound_ds.exe with no luck. Tried it in different orders, nothing.
    But the game does run on my laptop.

    Here’s the autoexec portion of the Wake of the Ravager .conf file.

    # Lines in this section will be run at startup.
    # You can put your MOUNT lines here.
    @echo off
    mount c “..”
    mount C “..\cloud_saves” -t overlay
    imgmount d “..\game.ins” -t iso
    goto launcher

    ECHO º —————————————— º
    ECHO º Dark Sun 2: Wake of the Ravager Launcher º
    ECHO º —————————————— º
    ECHO º 1) Dark Sun 2: Wake of the Ravager º
    ECHO º 2) Game DOS Settings º
    ECHO º —————————————— º
    ECHO º 3) exit program º
    ECHO º —————————————— º

    choice /c123 /s Which program do you want to run? [1-3]: /n
    if errorlevel 3 goto exit
    if errorlevel 2 goto setup
    if errorlevel 1 goto game

    goto exit

    goto launcher



    Thanks for the help!

    Al ex

    Yes, that’s the “tricky setups” i was referring to. Someone over at GoG really loves to code DOS batches. ?

    Anyway, you will probably have to configure Magic Dosbox using the [autoexec] section at the bottom of the expert settings. That’s the equivalent to the .conf file (in fact, it is the .conf file). And here’s where the fun begins. ?

    Forget about the whole part starting with “goto launcher”; that’s all just a gimmick to allow you access to the setup.

    All you need is this part:
    mount c “..”
    mount C “..\cloud_saves” -t overlay
    imgmount d “..\game.ins” -t iso

    In your case, let’s assume the game files and the game.ins image are on the internal sd card, in a folder/subfolder called “DOSGames/Ravager”. In that case, you should type something like this:

    mount c /storage/sdcard/DOSGames
    imgmount d /storage/sdcard/DOSGames/Ravager/game.ins -t iso

    If the mounting is correct, and you’ve set the “expert settings” checkmark, the profile will boot into DOS, to your virtual C:\ root (the “DOSGames” folder on your sdcard).
    Now, type (and hit enter) either “D:” to access the cd image, or “cd ravager” to enter the game directory. From here, you can launch the setup, configure the game, and run it. If everything works as intended, add these two lines to the autoexec section, so the game will autostart next time:

    cd ravager

    This will autostart the game when you launch your profile, and shut down the profile automatically when you exit the game.

    Hope this helps… ??


    I followed your instructions and applying the mounting instructions worked exactly as they should.
    But when I go to run the game, it just crashes me out of dosbox.
    I tried running it with and without running the sound setup and the patch, every different combination. The crash is the same each time when I change to the Ravager directory and run the ravager.bat.
    It still doesn’t even recognize the dsun.exe.
    Very weird!

    As far as I can tell, there doesn’t seem to be a CD image file. That would be an iso file, right?

    Whether or not I get it running, I really appreciate your help. I feel like I’m now a little better equipped to deal with future problems with other games just knowing about the expert commands feature.

    Al ex

    Hm, let’s see. Yes, if it’s looking for the CD, it’s the game.ins file you need. GoG are using weird iso file extensions, but they’re basically just iso files. After all, Dosbox must be able to access them.
    Can you change to drive D: in Magic Dosbox?

    Maybe another solution: I take it you preinstalled the game on your PC? GoG installs games to a subfolder, but mounts that folder as “C:\”. I wouldn’t advise to do so, simply because IMHO no game should be installed to C:\, but that’s just a habit of mine. Try this:

    mount c /storage/sdcard/DOSGames/Ravager
    imgmount d /storage/sdcard/DOSGames/Ravager/game.ins -t iso

    If that doesn’t help, but you can access drive D: in Magic Dosbox, try a complete reinstall, so the game will get the correct path settings.


    I can change to drive D no problem.
    I don’t have an sd card, just the internal storage of the phonem. It’s a OnePlus 7 pro. No SD card possible, just the 256 gb it comes with.

    So my path is “drive D is mounted as /storage/emulated/0/dosgames/Ravager/game.ins”

    When I change to D: and type “Ravager,” it just crashes. Seems like that should run the game, but it just doesn’t work.
    In the game files, there’s a ravager.bat and a dsun.exe.
    I could have sworn I used to just type dsun and it would run many years ago when I played the game on actual dos.
    Anyway, when I mount the d drive as you described and switch to D: and try typing dsun, I get this:

    DARKSAVE.GFF to DARKRUN.GFF failed. Path = D:\

    Al ex

    Uh, so the initial mounting was probably better. I’m almost tempted to buy the game, only to try this out.

    In the profile settings, do you have SVN core enabled? If so, please turn it off (or vice versa). Switchting between vanilla Dosbox and SVN can sometimes fix crash issues.


    Nope, I didn’t have SVN enabled.

    Oh, well. Honestly, the game really isn’t as good as the first one anyway!

    It’s just that thing where you can’t get something to work and it becomes more about getting it to work than actually playing the game. Haha

    I appreciate all the help. I wouldn’t be at all surprised if the issue is user error on my part.

    The first game, Shattered Lands, is a really great RPG. You get both in one collection on GOG. It goes on sale fairly often for like $5.
    If you ever get the game, I’ll be very curious to know if you find a solution.

    Thanks again!


    Alex is right, looking at the config file, you only need mount drive c to folder in which is the iso file, then mount iso file and run ravager from subdirectory to directory in which is iso file.

    Do fresh copy from pc and dont forget “safely remove device” on windows taskbar

    Al ex

    |it becomes more about getting it to
    |work than actually playing the game.

    Lol I’m with you on that. I just *hate* it when I know I’m close, but can’t quite figure out what’s wrong. Can be anything, even a simple typo (that’s my signature mistake ?).

    If I get my hands on the game, I’ll see what I cam find out. As a general rule, if it’s working in Win/Linux Dosbox, it’s also working in Magic Dosbox.


    Admin, there is no iso file.

    Al ex

    He’s talking about the game.ins file. GoG have a habit of renaming iso files to something unrecognizable. ?


    Hi, I have a problem with Dark Sun Shattered Lands, it too is GOG’s version, but a non CD version of the game. I have both Dark Sun games, but I could not find any other thread for Shattered Lands so I will post here if it’s okay.

    The issues I have with Dark Sun Shattered Lands, is when I do the basic set up in Magic Box, when I launch the game, it flashes with white text quickly then exits.

    So what I did was copy the text from the dosbox_darksun.conf file from GOG’s version into the expert mode and tried to launch the game again. This time it just brings me to c: prompt. I am able to cd command all the way to the game directory on my phone and launch the game that way. No matter what else I try to type for the mount function, it will not mount or tell me it can not mount etc. Only if I copy the GOG’s version of the ini file, launch it, then falls back to the c: prompt.

    Here is a copy of the dosbox_darksun.conf settings I have in expert that I can navigate to get into the game. Maybe you could identify what I should be adding to the dosbox_darksun.conf settings to launch it from the external launcher as per usual.

    Also first, here are the settings for Magic DosBox I have set to launch this game.

    “Title – Dark Sun”
    Checked Use SVN core, does not effect the game as far as I can tell.

    Drive C:\
    /storage/emulated/0/aGamesbacks/Dark Sun (I have my games folder for all my games “aGamesbacks” located in the internal storage.


    PC speaker checked, doesn’t seem to effect the game,
    Sound Blaster 16
    Midi: Off

    xms, ems, umb all are checked

    CD-ROM is unchecked as GOGs version of Shatterelands is the non CD version

    Network – nothing changed

    Joystick – nothing changed

    Main program


    Expert – Checked settings below, again it brings me into c: and I can manually direct myself to the games folder and launch it that way.

    # language: Select another language file.
    # machine: The type of machine DOSBox tries to emulate.
    # Possible values: hercules, cga, tandy, pcjr, ega, vgaonly, svga_s3, svga_et3000, svga_et4000, svga_paradise, vesa_nolfb, vesa_oldvbe.
    # captures: Directory where things like wave, midi, screenshot get captured.
    # memsize: Amount of memory DOSBox has in megabytes.
    # This value is best left at its default to avoid problems with some games,
    # though few games might require a higher value.
    # There is generally no speed advantage when raising this value.


    # frameskip: How many frames DOSBox skips before drawing one.
    # aspect: Do aspect correction, if your output method doesn’t support scaling this can slow things down!
    # scaler: Scaler used to enlarge/enhance low resolution modes. If ‘forced’ is appended,
    # then the scaler will be used even if the result might not be desired.
    # To fit a scaler in the resolution used at full screen may require a border or side bars,
    # to fill the screen entirely, depending on your hardware, a different scaler/fullresolution might work.
    # Possible values: none, normal2x, normal3x, advmame2x, advmame3x, advinterp2x, advinterp3x, hq2x, hq3x, 2xsai, super2xsai, supereagle, tv2x, tv3x, rgb2x, rgb3x, scan2x, scan3x.


    # core: CPU Core used in emulation. auto will switch to dynamic if available and
    # appropriate.
    # Possible values: auto, dynamic, normal, simple.
    # cputype: CPU Type used in emulation. auto is the fastest choice.
    # Possible values: auto, 386, 386_slow, 486_slow, pentium_slow, 386_prefetch.
    # cycles: Amount of instructions DOSBox tries to emulate each millisecond.
    # Setting this value too high results in sound dropouts and lags.
    # Cycles can be set in 3 ways:
    # ‘auto’ tries to guess what a game needs.
    # It usually works, but can fail for certain games.
    # ‘fixed #number’ will set a fixed amount of cycles. This is what you usually
    # need if ‘auto’ fails. (Example: fixed 4000).
    # ‘max’ will allocate as much cycles as your computer is able to
    # handle.
    # Possible values: auto, fixed, max.
    # cycleup: Amount of cycles to decrease/increase with keycombos.(CTRL-F11/CTRL-F12)
    # cycledown: Setting it lower than 100 will be a percentage.

    cycles=fixed 7000

    # nosound: Enable silent mode, sound is still emulated though.
    # rate: Mixer sample rate, setting any device’s rate higher than this will probably lower their sound quality.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # blocksize: Mixer block size, larger blocks might help sound stuttering but sound will also be more lagged.
    # Possible values: 1024, 2048, 4096, 8192, 512, 256.
    # prebuffer: How many milliseconds of data to keep on top of the blocksize.


    # mpu401: Type of MPU-401 to emulate.
    # Possible values: intelligent, uart, none.
    # mididevice: Device that will receive the MIDI data from MPU-401.
    # Possible values: default, win32, alsa, oss, coreaudio, coremidi, none.
    # midiconfig: Special configuration options for the device driver. This is usually the id of the device you want to use
    # (find the id with mixer/listmidi).
    # Or in the case of coreaudio, you can specify a soundfont here.
    # See the README/Manual for more details.


    # sbtype: Type of Soundblaster to emulate. gb is Gameblaster.
    # Possible values: sb1, sb2, sbpro1, sbpro2, sb16, gb, none.
    # sbbase: The IO address of the soundblaster.
    # Possible values: 220, 240, 260, 280, 2a0, 2c0, 2e0, 300.
    # irq: The IRQ number of the soundblaster.
    # Possible values: 7, 5, 3, 9, 10, 11, 12.
    # dma: The DMA number of the soundblaster.
    # Possible values: 1, 5, 0, 3, 6, 7.
    # hdma: The High DMA number of the soundblaster.
    # Possible values: 1, 5, 0, 3, 6, 7.
    # sbmixer: Allow the soundblaster mixer to modify the DOSBox mixer.
    # oplmode: Type of OPL emulation. On ‘auto’ the mode is determined by sblaster type. All OPL modes are Adlib-compatible, except for ‘cms’.
    # Possible values: auto, cms, opl2, dualopl2, opl3, none.
    # oplemu: Provider for the OPL emulation. compat might provide better quality (see oplrate as well).
    # Possible values: default, compat, fast.
    # oplrate: Sample rate of OPL music emulation. Use 49716 for highest quality (set the mixer rate accordingly).
    # Possible values: 44100, 49716, 48000, 32000, 22050, 16000, 11025, 8000.


    # gus: Enable the Gravis Ultrasound emulation.
    # gusrate: Sample rate of Ultrasound emulation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # gusbase: The IO base address of the Gravis Ultrasound.
    # Possible values: 240, 220, 260, 280, 2a0, 2c0, 2e0, 300.
    # gusirq: The IRQ number of the Gravis Ultrasound.
    # Possible values: 5, 3, 7, 9, 10, 11, 12.
    # gusdma: The DMA channel of the Gravis Ultrasound.
    # Possible values: 3, 0, 1, 5, 6, 7.
    # ultradir: Path to Ultrasound directory. In this directory
    # there should be a MIDI directory that contains
    # the patch files for GUS playback. Patch sets used
    # with Timidity should work fine.


    # pcspeaker: Enable PC-Speaker emulation.
    # pcrate: Sample rate of the PC-Speaker sound generation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # tandy: Enable Tandy Sound System emulation. For ‘auto’, emulation is present only if machine is set to ‘tandy’.
    # Possible values: auto, on, off.
    # tandyrate: Sample rate of the Tandy 3-Voice generation.
    # Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
    # disney: Enable Disney Sound Source emulation. (Covox Voice Master and Speech Thing compatible).


    # joysticktype: Type of joystick to emulate: auto (default), none,
    # 2axis (supports two joysticks),
    # 4axis (supports one joystick, first joystick used),
    # 4axis_2 (supports one joystick, second joystick used),
    # fcs (Thrustmaster), ch (CH Flightstick).
    # none disables joystick emulation.
    # auto chooses emulation depending on real joystick(s).
    # (Remember to reset dosbox’s mapperfile if you saved it earlier)
    # Possible values: auto, 2axis, 4axis, 4axis_2, fcs, ch, none.
    # timed: enable timed intervals for axis. Experiment with this option, if your joystick drifts (away).
    # autofire: continuously fires as long as you keep the button pressed.
    # swap34: swap the 3rd and the 4th axis. Can be useful for certain joysticks.
    # buttonwrap: enable button wrapping at the number of emulated buttons.


    # serial1: set type of device connected to com port.
    # Can be disabled, dummy, modem, nullmodem, directserial.
    # Additional parameters must be in the same line in the form of
    # parameter:value. Parameter for all types is irq (optional).
    # for directserial: realport (required), rxdelay (optional).
    # (realport:COM1 realport:ttyS0).
    # for modem: listenport (optional).
    # for nullmodem: server, rxdelay, txdelay, telnet, usedtr,
    # transparent, port, inhsocket (all optional).
    # Example: serial1=modem listenport:5000
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial2: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial3: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.
    # serial4: see serial1
    # Possible values: dummy, disabled, modem, nullmodem, directserial.


    # xms: Enable XMS support.
    # ems: Enable EMS support.
    # umb: Enable UMB support.
    # keyboardlayout: Language code of the keyboard layout (or none).


    @Echo Off
    mount c: /mnt/sdcard/


    I am also trying to get Ravenloft Stone Prophet to work, but unable. This one I believe is the GOG CD version and I will try the suggestions above to see if I can not get it working or not.

    Also, I found for some reason, and I am not sure if it’s a CD version or not, but also from GOG, is Ishar 3, 1 and 2 were fine to get setup and running.

    So I am only having troubles getting Dark Sun Shattered Lands, Ravenlofts Stone Prophet and Ishar 3 from working. And according to the compatibility list, they should be able to.

    I realize this is long, but I wanted to be thorough and hopefully you can help me. I have a large collection of GOG’s All Forgotten Realms SSI games, Ultima’s 6-8 Underground 1-2 3D Realms full collection,-(Non GOG), Realms of Arkania 1-3 Might and Magic 3-5, Heroes of Might and Magic 1,2 Warcraft 1,2 Ishar 1,2 Bloodstone, Conan the Cimmerian, Hexx, Wizardry 7, Anvil of Dawn, Albion, Betrayal at Krondor, Darklands, Deathbringer, Jazz Jackrabbit, Tyrian, The Chaos Engine, The Adventures of Willy Beamish, Larry Suit 7, Batman, Fievel Goes West, Beverly Hills, Black Sect, Burn Time, Curse of Enchantment, Martian Memorandum, Mean Streets, Once Upon a Forest all set up and working in Magic Dos Box.

    I tried last night to get Daggerfall to work and followed the Youtube tutorial, but just could not get it to launch. I will play around with it again at a later date. I would like to solve the first 3 first.

    Thank you kindly, and thank you for the great effort to make a really good app for Android.

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.