Unable to Add Games or Save Settings

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #9991

    Hi, I’m 90% sure the issue is related to some Android permissions “feature”. I’ve used Magicbox on two phones, Pixel 3 and a Galaxy S 22. No issues on both, great application.

    I got a new tablet: Samsung Galaxy Tab S8 SM-X700 | Android Version 13 (I can give you build numbers if that helps) and I cannot add any games to Magicbox and it does not save any settings.

    I have tried setting the data and game paths to a storage location on the SD card, on the main storage, in the root of Magicbox, in a newly created folder on the main storage and it does not change behavior. Games added will not be there when I reboot and my settings are not saved, like my icon choice.

    The setting SD-Card and storages states: Direct file access: Disabled. I do not see any method to request storage permission.

    Any ideas? I am happy to experiment or read other posts that deal with this problem. Many thanks! Great app!



    So, you can add game profiles in mdosbox main menu, you can run game, however all profiles disappear after device reboot?

    “Direct file access: Disabled.” – means that this version of magic dosbox is not capable to work directly with public storage, it must use these stupid storage restrictions on devices with android11+. Version on huawei store can do it.


    I can add and play a game. It will remain as long as the session for Magicbox is up. When I reboot Magicbox, it is all gone. I will try the version on the huawei store. Thank you for the reply!

    An idea for a work around, I use an emulator frontend on Android called Launchbox. It has been a good workaround for launching roms on the SD card to an emulator (usually retroarch). It supports adding custom emulators to pass the game file to. It asks for the following for the following fields when adding a custom emulator:

    Custom Emulator Package Name
    Custom Emulator Activity Name
    Custom Emulator Rom Path Key

    Is there any Magicbox documentation that states what some of these items could be?

    Thanks Again!


    Hm, this is weird. It does the full version or free?

    >An idea for a work around, I use an emulator frontend on Android called Launchbox

    Launch a Magic DOSBox game with ARC Browser (or any other app)

    It was discussed, check link above. But I am not sure that it will work with that bug you face.

    If you start Magic Dosbox, do you see survey or it jumps to empty main menu?
    Did you check the directory where should be settings saved? Is there something after wipe?


    Thanks again for the reply and link. I will check it out.

    I did a fresh install of Magicbox, the paid version. Here is what I did and what I experienced.

    Fresh Install from Google Play Store (I’m in the US and apparently we block the huawei sign-up process)
    Grant permission to access photos and videos.
    Welcome screen appears.
    Games Folder selection is prompted.
    I select a newly created folder, MS-DOS on the device’s main storage area.
    I give Magicbox permission to access files in that folder.
    Next, I select game layout and settings location.
    I select a newly created folder, .magicbox on the device’s main storage area.
    I select modern icons.
    I close help and unselect “show at startup”
    I add a game, Civilization in a Civilization folder in the MS-DOS directory.
    The game appears in Magicbox as a selectable item.
    Launching game (civ.exe) causes Magicbox to crash.
    I relaunch Magicbox, no game is present to start. Icons have reverted to non-modern icons. Help screen appears again.
    In the .magicbox folder the following is present:

    Games (Folder)
    Data (Folder)
    e2e706….(Folder with random looking name)
    Temp (Empty Folder)

    I tried adding Civ two additional times and there are two new folders in the DATA folder after doing so. The game does not remain in Magicbox after adding it. I can paste the contents of any file if needed. Thanks again for the help! Hopefully other users will get some support from this.


    I had tabs to show the file structure. but they were removed when I submitted the post. Here is the content of the .magicbox folder with four “_” replacing each tab.

    .magicbox folder has the following in it
    ____Games (Folder)
    ________Data (Folder)
    ____________e2e706….(Folder with randoming looking name)
    ________________Temp (Folder)


    Looks like everything is there. Can you make screenshot of your global settings? Please send it here magicbox@imejl.sk

    Btw, did you try device restart? Because this is very weird


    I did try a restart and no change in the behavior. I sent you an email with the requested image. Again, many thanks!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.