Nexus 7 2013 No sound

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2134

    I can’t seem to get any sound from my games on a Nexus 7 2013.

    I have tried my Ultimas and Wasteland with different setups (my own and from .mgc forum) but I just can’t get any sound when the games start up.

    I am able to get sound when I open them in DosBox Turbo though.

    Anyone else getting it to work on a non-rooted, 2nd generation Nexus 7 5.0.2 or know what the problem could be?

    Edit: I just installed Fallout and used the .mgc from the forum and the sound seems to work for that. Just not any of my Ultimas.



    I owned nexus 7 2013. Great device without sound problems. Please can you export game which has sound trouble and share it together with game data? These games are playing people daily. I believe that there must be only some wrong setting. Do you use expert settings or run game through GUI? Maybe you use dosbox turbo config which is not 100% compatible with magic dosbox. Both emulators are a bit different.


    Was necessary to restore db from 20.2, so I am adding missing answers :


    Which Ultima games are you having problems with? I have every Dos Ultima running without problems on my Nexus 7.

    Wasteland just uses the PC speaker for sound, so make sure the PC Speaker box is checked. I don’t think it’s on by default. That goes the same for some of the earliest Ultima games.


    Ok, it seems to be working now. When I start the Ultimas from the default GUI or with your (ChrisG) .mgc’s, I don’t get any sound. If all I do is check the Expert settings then it will work.

    I also just tried turning PC Speaker on, as you suggested and that seems to work with default and your .mgc’s.

    Thanks guys!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.