Fluidsynth

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #7861
    jd
    Participant

    Hi just need some help getting Fluidsynth sounds to work.
    I have my sf files and choose synth from midi choose my sf file and in Dott select gen midi and port 330 start the game and I get no music just voice. I’m using the cd version of the game.

    Thanks in advance

    Jd

    #7862
    Al exAl ex
    Keymaster

    Should work out of the box by using Magic Dosbox’s UI setup. I did the exact same steps as you: Midi:synth, select sf2 file (General_User_GS_Fluidsynth_v1.47.sf2), configured DOTT to use Gen MIDI Port 330, and it’s working.

    That said, let’s look for the reason why it isn’t working for you.
    • First off, please make sure there are no spaces in the file name of your .sf2 file. I think I recall there were some issues with that in Dosbox in general.
    • Next, try the sound font I mentioned above. It’s free, and sounds really good (http://www.schristiancollins.com/generaluser.php).
    • If it still doesn’t work, try it with another game, to see if it’s an isolated issue with your DOTT copy.

    Good luck! ??

    #7863
    Al exAl ex
    Keymaster

    Oh, and one more thing: make sure you set the frequency to 44100 or 48000 Hz (the cogwheel at the top right of the “Sound” section). MIDI music sounds awful at lower audio frequencies, it’s all distorted. 44.1 kHz is fine, 48kHz is perfect.

    #7864
    Al exAl ex
    Keymaster

    Aaaand I just saw you’re using the CD version. Is it possibly looking for CD audio tracks instead?

    #7865
    jd
    Participant

    I’ve tried the sf that you have pointed to taken the spaces out still with no joy also tried with settlers 2, which detected gen midi but no music in game. Very puzzling I remember dis been a pain mt32 works a treat though so it’s no great biggie

    Thanks for the reply

    J

    #7866
    Al exAl ex
    Keymaster

    Still quite strange. Fluidsynth is running fine in any game I’ve thrown it at so far, even when used as MT32 replacement, though that can sound rather horrible. Maybe (unless you haven’t already) copy the sf2 file to a standard directory, like /sdcard/Downloads, and see if that will help.
    Because if you’re getting MT32 sound, MIDI output is definitely working on your device. No synth music output rather indicates that Dosbox can’t find/access the soundfont file.

    #7867
    jd
    Participant

    That worked but strange it can mount my external drive fine Gus works fine and my-32 files, anyway I’m not going to stress about it, not like the sf files are like gigs big.

    Thanks for all your help and
    Tought me not to assume things
    Are working:p

    Best regards

    J

    #7868
    Al exAl ex
    Keymaster

    You’re welcome. ? In some games, like Warcraft 2, Fluidsynth sounds great, sometimes even better than the original CD music.
    (External drives are a mess ever since the latest Android OS upgrades. ?)

    #7869
    adminadmin
    Keymaster

    Empty spaces are not problem, i fixed it. How did you get soundfont to standard directory? Was copied from non workind directory or downloaded again? I am asking, because maybe that file in first location was broken.

    #7877
    jd
    Participant

    Sorry for the long delay in answering I’ve been away, anyway I copied from the nine working dir.

    Also I’m back and android tvbox updated itself wiped my SDcard so had to start again.

    This problem is back where ever I put the files now, mt32 works perfect even if files are on external harddrive.

    #7878
    Al exAl ex
    Keymaster

    You mean, it stopped working again!? Weird. Have you tried to put the .sf2 file in the /Download directory, or some other basic directory on your internal sd card?

    #8573
    MichaelNA2005MichaelNA2005
    Participant

    How can I make fluidsynth (.sf2) work on Expert commands?

    #8574
    adminadmin
    Keymaster

    Hi,

    best way is set fuildsynt in gui. Then go to main program section in google profile. There is button on right side called get and let it generate expert settings from gui

    #8575
    Al exAl ex
    Keymaster

    Looks like this in my expert settings:

    [midi]
    mpu401=intelligent
    mididevice=synth
    synth.sample-rate=48000
    synth.gain=2
    midiconfig=/storage/emulated/0/.MagicBox/MidiROM/GeneralUser_GS_FluidSynth_v1.47.sf2

    It’s important to set the sample rate t at least 44 kHz, because the sound quality suffers badly at anything below. 22.5 kHz sounds really horrible. 🙂

    #8576
    MichaelNA2005MichaelNA2005
    Participant

    Thanks a lot! 🙂

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.