Dune (1992) no sound

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #8355
    Dangel
    Participant

    I recently wanted to try this gem and thought it would be cool to play it on mobile. I got everything installed and even the controls are working fine. But I get no sound no matter what I do. The games own settings are set to soundblaster and I tried all of the soundblaster versions available. I tried with PC speaker on and off, I even installed a soundfont to try if midi works. Funny thing is, whenever I manually change the settings using the install.exe I hear a short “click” as confirmation sound but as soon I start the game there is silence. I’m not sure what I am doing wrong.

    #8356
    Al exAl ex
    Keymaster

    Kind of my default answer by now ?, but it’s working fine for me.
    Creating a new, empty layout, then I simply add dune2.exe as main and setup.exe as setup file. Run setup, configure sound to Sound Blaster Pro, save. Then launch the game.

    Are you using a special version of the game?

    #8357
    Al exAl ex
    Keymaster

    Np wait, ignore my reply! I was testing Dune 2. ? Let me check on Dune…

    #8358
    Al exAl ex
    Keymaster

    OK, found the solution here: https://forum.dune2k.com/topic/21510-problem-solution-dune-in-dosbox-without-sound-what-to-do/

    1. in your profile’s Software settings, select duneprg.exe as Main program
    2. click the small cogwheel icon, and paste the following line: ENG VGA SDB2207 EMS 386
    3. make sure you’ve set the sound config to Soundblaster for music & sound (or configure it accordingly)
    4. run the game

    That’s my test profile: http://www.mediafire.com/file/55jfkowa6dkpiml/Dune.mgc/file
    Just adjust the path settings, and you should be good to go.

    #8359
    Dangel
    Participant

    Thank you very much! I tried your solution and added the line for dunerpg.exe but it didn’t work. I then did it manually in the dune.bat file like suggested in the forum you linked. That worked. But only if I manually start dune in dos after starting install.exe. If I only start it from the main menu there is no sound.

    Btw, I derped in the title, too. I wanted to make it clear that I mean the first dune and put 1992 in parenthesis not thinking about the fact that both titles came out in 1992.

    #8360
    Al exAl ex
    Keymaster

    Not your fault, it clearly says “Dune” in the title, not “Dune 2”. ?
    Have you tried my profile?

    #8361
    Dangel
    Participant

    Not yet. This is the first time I’m using magic dosbox so I started of with the free version where profiles are not allowed to be imported.

    #8362
    Al exAl ex
    Keymaster

    Ah, alright. ?

    Here’s how to do it, and please forgive the crude markup, I’m fascinated by my phones screen recording feature. ?
    http://www.mediafire.com/file/ri1ev0jh8kd3c2d/Screen_Recording_20201012-202554_Magic_DosBox.mp4/file

    #8363
    Al exAl ex
    Keymaster

    Oh, and welcome! ?

    #8364
    Dangel
    Participant

    Thanks for the video. Unfortunately that’s exactly what I did and it doesn’t work. I apparently have to live with starting the game through the install.exe. I tried the CD version now since I had the non-voiced version before but it’s the same there.

    #8372
    M4sterm4ge
    Participant

    Hi,
    I just found this Magic Dosbox to use old Dos games.
    And the first game that came to mind was Dune.
    I played this a ton back in the day.

    I grabbed the Iso from:
    [link removed due to copyright violation]
    (Which is legal, I hope)

    Mounted the cd in Magic Dosbox.
    Ran the setup. Choose the soundblaster for sound.
    Then everything worked and with sound when I started the game. With voices and all.
    Be sure to check the box of the mounted CD in the settings of the game in Magic Dosbox.
    Because the sound is located on the CD. Only settings and saves are stored on the “disk”.

    This game works great on my Galaxy Tab 2 10 inch with stock android 4.4.
    I would also suggest to use the absolute mouse setting and adding a ‘esc’ button (so you can skip the intro’s if you wish).

    Hope this helps!

    #8373
    Al exAl ex
    Keymaster

    Unfortunately, I had to disable the link. Game downloads are illegal unless the game has been officially been released as freeware. Even if they’re labelled “abandonware”, it’s technically still piracy. ¯\_(ツ)_/¯
    But thanks for providing help. 🙂

    #8374
    M4sterm4ge
    Participant

    No problem. I think it is freely available now. But I understand.
    But enabling the cd/iso was key for me to get the sound up and running. I hope it helped.

    #8375
    Al exAl ex
    Keymaster

    I think Dune 2 is free now, but I’m not sure about that either. Most likely noone even would even care, but better safe than sorry. 🙂
    Anyway, maybe your fix will work, thanks for that!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.