Age of empires 1 not working because of low vram

Viewing 11 posts - 31 through 41 (of 41 total)
  • Author
  • #4360

    Alright after reading what you said my brains is still kinda slow to understand it .. lol .

    Ok so its like this .. I just downloaded AgeOfEmpires1.ISO from the WinWorld website & I recently found the AgeOfEmpires.mgc config shared by you on the other section. (Private MGC Sharing Section)

    Then I downloaded the HDD and extracted it .. So now I have 3 files that is the :

    So what should i do from here?
    You also said to copy the AgeOfEmpire to the HDD? How am i suppose to do it? It Needs a program or something?

    Al ex

    OK, let’s just forget you said you pirated the game, and assume that at least your Win95 installation is legal…?

    1. use a tool like UltraISO (which is shareware) to open the hdd-2gb.img file. Copy the AgeOfEmpire.iso into this img file, and save.
    2. Copy the hdd-2gb.img and Age_of_Empires.mgc to your sdcard
    3. Open Magic Dosbox, press the orange “+” symbol at the left, then “Import profile”; search Age_of_Empires.mgc, and open it.
    4. Long-press the imported AoE profile, tap “edit”, scroll down to “Expert commands”, and click on the edit button.
    5. Adjust the mountings at the bottom of the conf file. They’re pointing to the file locations on my device, which are of course completely different from yours.

    You can ignore/delete the first imgmount command (A: drive), I’m using this to do automated backups to a virtaul floppy drive, which I sync automatically to my Drive account.
    Place the correct mountings for drives C: and D:, then accept the changes (important! Press the green check button, or the changes will be lost), and lauch the profile. If the mountings are correct, you’ll have both drives available in Win95.


    Alright i have not done it yet but just a quick read through your instructions and i think i’m starting to understand. I will come back here if i need help .

    P/S: About the pirating .. I only pirate this kind of games .. more over this game is 90% of my childhood . So i will do whatever it takes to play this game hehe. 😛

    Al ex

    Well, it’s neither on GoG, nor on Steam, so wtf… ?


    Wadafak xD


    Thanks ALEX! Finally it worked on the first try. I just had a problem it would not start and its like

    F1 : Default

    But then i went in and out multiple times to check the config and i didnt notice that i left out the .img at the back of the image name hehe. After i fixed it then everything works . Thank you so much for the Guides and everything .. i appreciate every single bit of it. 🙂 #LoveYou #NoHomo xD

    Edit : Games kinda laggy . Any Solution?
    Im using Samsung Galaxy J7 Prime.

    Al ex

    Glad you got it working. But I fear you will have to live with the performance issues. Your phone has an Exynos 7870 cpu, clocked at 1.6 GHz. My wife’s Galaxy A5 has the similar Exynos 7880, and it’s performing really, but for Win95 you need more horsepower.
    The A5 is about as fast as my old Note 4, and that one was struggling with Win95 emulation.

    If you’re rooted, you can try to set peformance governor, and overclock your device.


    I see .. I tried playing AOE on ExaGear Strategies which i just found out about this app .. it runs smoother than MagicDosBox .. But i just dont like the controls/resolution and it does not support game MIDI sound files. But it runs better than MagicDosBox (For me) ..

    Yeah my android device is rooted .. i tried finding app that do overclocking on AppStore and i found one .. i max up all the GHZ and it just a tiny bit improvement in speed on the game. But not great , still feeling the lag.

    I can just play AOE on my computer and not go through all this trouble .. but i don’t get to spend my time at my computer cause im out working always. So i need portable devices that supports my favorite game. (Its obvious getting a Laptop should’ve done the trick cause its portable but its too big to carry around)

    Update(Edit) : I used ExaGear Strategies and played around with the settings and i read the setting guide and everything . I found a solution to the Fullscreen mode. and i manage to get the game to run smoother on Exagear .. i just set the game resolution itself to 640×480 and then i set the Exagear resolution for the game to the same exact 640×480 and it ran smoother than it was before (it was 800×600 before) . And also it supports Relative(Helium) & Absolute(Cuprum) controls which are named differently in the Exagear app but it works the same. So i guess this will solve my problem. Its sad how i can’t use the MagicDos. But i will keep the Windows95 on there just for some nostalgia feeling. 🙂

    Anyways thank you Alex for all the time and guide you gave me.
    Since you said your wife’s A5 has the same chip as my j7 prime phone .. why not testing it on her phone and just use ExaGear Strategies app and run AOE on it .. Just to test the difference between the MagicDos one and Exagear

    If you already know about the Exagear then give it a comparison test and see which is faster/smoother.

    Al ex

    Exagear is definitely smoother, because it’s not an emulator, but a (crude) W.I.N.E port. But it’s so woefully broken in many aspects, I don’t ever use it.
    Magic Dosbox on the other hand, being a real emulator, needs much more processing power, but offers much better conpatibility especially for DOS games.

    I compared performance on my old Note 4, with Diablo 2. It was unplayably slow in Magic Dosbox, but sort of worked in Exagear. Sadly, the Exagear controls were so poorly designed, it was a PITA to play.

    Now on my S7 Edge, Diablo 2 runs perfectly smooth in Magic Dosbox, so there’s no need for Exagear anyway.

    What you can do is download the Doom shareware v1.9, and execute it with “doom timedemo -demo3”. The resulting realtics score (2134 gametics in xxxx realtics) will show you how fast your cpu can run Dosbox.
    For reference:
    S7 (Exynos 8890): 650 realtics (~Pentium MMX 233/AMD K6 300)
    Note 4 (Snapdragon 805): 2200 (stock), 1400 (heavily tweaked)
    Galaxy A5 (Exynos 7880): 2000 realtics (and I won’t tweak my wife’s phone, she’ll murder me if I brick it?).


    Thank you Alex, for help on this forum. Your knowledge is much better in this case then mine:)

    Yes, exagear emulates win9.x in many cases faster and in many cases buggy. But with strong devices this limitation slowly fades. Fortunately games like diablo 1, starcraft 1, Fallout 2, Jazzjack rabbit 2 and many other works well and you can enjoy all mDosbox features 🙂


    Yeah i totally agree that ExaGear has poorly design controls and the fact that it’ll slowly be useless in stronger devices just like admin mention. But Exagear will be good for the time being while i have my J7 Prime.
    Anyways thank you Alex & Admin for help and the time given to help. Good day and take care 🙂

Viewing 11 posts - 31 through 41 (of 41 total)
  • You must be logged in to reply to this topic.