Reply To: Duke nukem 3d too slow

Al ex

Lol, hopefully.?

First thing to do is enter your game profile settings by long-pressing the icon, then tap “Edit”. Scroll down to “Performance”, and check “cycles: max”.
That should already do the trick, at least on the Exynos S7 variant, which is imctedibly powerful when it comes to emulation.

If your S7 has the Snapdragon chipset instead of Exynos, it may be too slow to run Duke 3D at higher settings. In that case, you need to launch the setup.exe in the Duke3D directory, and select a lower video mode, e.g. 640×480, or 320×200.