Al ex

Forum Replies Created

Viewing 15 posts - 976 through 990 (of 1,020 total)
  • Author
    Posts
  • in reply to: Age of empires 1 not working because of low vram #3781
    Al ex
    Keymaster

    Set your graphics adapter to “S3 Inc. Trio 32/64 PCI”. That’s the one that’s being emulated by Dosbox, and it supports up to 8 MB of VRAM.
    You probably need the drivers, you can either find them on your Win95 cd, or in the Win95 thread on the official Dosbox forums. Or simply google “S3 Inc. Trio 32/64 PCI windows 95 driver”. ?

    Put them somewhere in your image file where you can find them. I’d suggest UltraISO for editing .img-files, you can do all you need with the unregistered free version.

    And check your mounting commands. Take a look at Roland Deschains guide on xda-developers, he’s also offering pre-configured images (Win95 & Win98lite).

    It’s a Dosbox Turbo thread, but DTurbo is buggy as hell, and these images also work with MagicDosbox. ?

    in reply to: Age of empires 1 not working because of low vram #3778
    Al ex
    Keymaster

    I haven’t uploaded them anywhere, and I’m at work, so I can’t share them atm. But there’s no need for that anyway: you can simply use your own mountings along with the rest of my settings. They were working before, so they should do now.
    The bug cannot be caused from bad mountings, so you can simply copy/paste my settings without the [autoexec] section and insert them into your profile.
    I’d suggest you take a look at your Win95 display properties, too. Sometimes, Win95 is running at 640×480, 16 colors. In this case, you need to set it to 256 colors first, or most games won’t run.

    in reply to: Age of empires 1 not working because of low vram #3776
    Al ex
    Keymaster

    It starts in 800×600, so you need to set manual mouse correction accordingly (Fix: msmouse, resolution 800×600)

    in reply to: Age of empires 1 not working because of low vram #3775
    Al ex
    Keymaster

    :-)

    in reply to: Age of empires 1 not working because of low vram #3774
    Al ex
    Keymaster

    This may be a stupid question, but have you set the colour depth in Win95 display properties to 256 or Hi-Color?

    AoE starts fine on my phone with these settings:

    [dosbox]
    machine=svga_s3
    memsize=32
    vmemsize=8

    [render]
    frameskip=2

    [cpu]
    # valid core are: normal, simple, full, auto, dynamic
    # dynamic is the fastest and optimized for the ARM processor + works with Win9x
    core=dynamic
    # new paging methods from MB6 & Ykhwong SVN introduce new cputype settings:
    # valid cputypes are: 386, 486, 386_prefetch (*), 486_prefetch (*), pentium, pentium_mmx
    # (*) = requires normal core setting instead of dynamic
    cputype=pentium
    cycles=max 105%
    cycleup=500
    cycledown=500
    isapnpbios=true

    [sblaster]
    sbtype=sb16
    mixer=false
    oplmode=auto
    oplemu=fast
    oplrate=22050

    [mixer]
    rate=22050
    blocksize=512
    prebuffer=5

    [dos]
    xms=true
    ems=false
    umb=true
    keyboardlayout=auto

    [ipx]
    ipx=false

    [joystick]
    joysticktype=none
    timed=false

    [midi]
    # Only enable MIDI if you have the necessary MT32 ROM files
    mpu401=none
    mididevice=none

    [speaker]
    pcspeaker=false
    tandyrate=8000
    tandy=false
    pcrate=8000
    disney=false

    [gus]
    gus=false

    [autoexec]
    @Echo Off
    imgmount c /storage/9C33-6BBD/Games/PC/Win95/c.img -t hdd -fs fat -size 512,63,32,520
    imgmount d /storage/9C33-6BBD/Games/PC/Win95/2GB_AoE1.img -t hdd -fs fat -size 512,63,64,1023
    boot -l c

    in reply to: Age of empires 1 not working because of low vram #3772
    Al ex
    Keymaster

    Strange, it should work. I’ll try it and get back to you.

    in reply to: Age of empires 1 not working because of low vram #3770
    Al ex
    Keymaster

    In expert settings, try this!

    [dosbox]
    machine=svga_s3
    memsize=63
    vmemsize=8

    I can set screen mode to Hi-Color (16 bit) with no problems.

    Al ex
    Keymaster

    Try this config file.

    – check the mountings. They all point to my own DOS Games directory still.
    – remove the imgmount a[…] line. It’s only in there because I’m using a floppy image to store backups of my Win95 savegames, in case the hdd image gets corrupted. I’m a bit paranoid there.?

    This setup runs fine for me. Of course, Win95 itself is a crash-prone POS, but it’s runnimg much better in MagicDosbox than it did on my real PC 20 years ago.?

    Oh, and for optimal performance (assuming you’re rooted), set governor=performance.
    Sadly, our Snapdragon cpu is quite sluggish when it comes to DOS emulation, but this helps a bit. Even my old Exynos Note 2 was faster…?

    Al ex
    Keymaster

    I’ve got a Note 4 N910F, which is pretty much the same phone as yours, with the same chipset/cpu.
    I have no troubles at all running Win95. But it’s a custom Win95 installation. I remember having incredibly annoying freezing and crashing issues with the Win95 & Win98lite installations from Roland Deschain’s xda site. Are you by any chance using one of these versions? If so, then they are to blame. Try a clean Win95 install from a Win95 CD, that should work.

    in reply to: diablo 2 bought from battlenet.com on magic dosbox #3705
    Al ex
    Keymaster

    Ah, so you’ve got it running already?

    in reply to: diablo 2 bought from battlenet.com on magic dosbox #3703
    Al ex
    Keymaster

    Uh… the battle.net website says “1.9 GB available hard drive space”, that’ll be a close one. If it will install at all, because on the same website, Windows XP is listed as minimum requirement.

    If the installer works, and if the file size is too large, maybe you can delete the video container file (d2video.mpq) during install, or replace it with a 0 Bytes dummy file during installation.

    Or you install it on your PC outside Dosbox, then copy the files to a 2 GB hard drive image file, and copy that to your phone. And hope it’s only the installer which needs WinXP, and the game itself will run in Win95.

    The last solution would be to get hold of the original CD version. Can’t point you to illegal downloads, obviously, and you’d still need a cd key, but the cd version is available e.g. on Amazon for a few bucks (the “Bestseller” series for 7 EUR), and that one’s officially listed as Win95 compatible.

    in reply to: diablo 2 bought from battlenet.com on magic dosbox #3700
    Al ex
    Keymaster

    Windows 95 doesn’t support more than two hard drives, so you’re out of luck – no drive e with 2 GB.

    But I think your other idea is good: use a 2GB Win95osr.img instead of only 512 MB, copy the installer there, then install the game to hdd-2gb.img, and delete the installer afterwards to free up space on your Win95osr volume again.

    For easy file handling, I suggest you use UltraISO. You can easily copy files to hdd images with this tool.

    And don’t expect too much. Diablo 2 is hardware hungry, it runs veeery slowly in mobile Dosbox, unless you have a very powerful phone (=rooted & tweaked Galaxy S7 or similar).

    in reply to: diablo 2 bought from battlenet.com on magic dosbox #3698
    Al ex
    Keymaster

    Can you run the game in the official Dosbox PC version? Sometimes, these classics come with modern installers and other tweaks that break Win95 compatibility.
    Try to set up your Win95 environment on a PC, that’s much easier.
    I’d suggest a “c.img” harddisk file for the Win95 installation, and a larger “d.img” harddisk file that should contain the installer. Install the game inside Win95 to another folder on this d.img drive.
    If your version is not compatible with Win95, the installation will close with an error message at this point already. If not, this will ensure everything is copied and registered where it belongs.
    If you get it working on your PC, you can copy both the c.img and d.img files to your phone and set them up in Magic Dosbox.

    in reply to: Daggerfall #3680
    Al ex
    Keymaster

    Thanks a lot!
    I’ve updated the post, I had messed up the downloads – v2.2 behind the v1.2 download.
    I’ve removed v1 conpletely now, as v2 should work better even for Daggerfall’s UI mode.

    in reply to: Better Swipes #3659
    Al ex
    Keymaster

    Sounds like a good solution. Or maybe you can also integrate an additional “Zoom mode” option into the “Two point tap” section of the Gestures menu; “Zoom mode” and “Mouse button control” excluding eacht other, and “Keep mouse button down” will only have an effect if Mouse button control is active.

    Fig. 1a:
    ✅ Enabled
    ⬛ Zoom mode
    ✅ Mouse button control
    ✅ Keep the mouse button down

    Fig. 1b:
    ✅ Enabled
    ⬛ Zoom mode
    ✅ Mouse button control
    ⬛ Keep the mouse button down


    Fig. 2:
    ✅ Enabled
    ✅ Zoom mode
    ⬛ Mouse button control
    ⬛ Keep the mouse button down

Viewing 15 posts - 976 through 990 (of 1,020 total)