Physical mouse problems.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #8557
    GrilledCheeseStick
    Participant

    When I try and use a physical mouse for a game like duke nukem 3D I’m limited on how much I can move my mouse. Also every time I left or right click I start strafing and cannot stop strafing until I turn off my mouse. Is there a way to fix this or does magic dosbox not like mice.

    #8558
    adminadmin
    Keymaster

    Hm, do you have configured duke for keyboard + mouse in setup? Did you activates “hide mouse pointer” with mouse wheel?

    #8559
    GrilledCheeseStick
    Participant

    I do have keyboard and mouse in setup, but how do you exactly hid the mouse cursor?

    #8560
    adminadmin
    Keymaster

    Press mouse wheel up (or down?, Dont 4remember) on physical mouse. You must have android 8+. What is your android version?

    #8561
    GrilledCheeseStick
    Participant

    Android 10

    #8562
    adminadmin
    Keymaster

    So it should work, if mouse wheel does not work then place special widget on the screen and configure it to hide cursor. Press it and physical mouse should be fully functional

    #8563
    GrilledCheeseStick
    Participant

    I figured out what you were talking about with hiding the cursor but I still strafe back and forth when I click one of the mouse buttons. It may be a problem with my mouse, I’m not sure.

    #8564
    adminadmin
    Keymaster

    Place virtual mouse widget on the screen. Configure it to click + left button. Back to play mode and press it. You can test this way right click as well. What happens?

    Best for testing physical mouse is warcraft 2 or command and conquer 1. If possible try these games what happens. If these games works then you have wrong setup in duke. In warcraft 2 you can test left click, left mouse down for selection and right click for deselection.

    If you hide cursor with mouse wheel or widget then it works like physical mouse on desktop pc. Nobody reported problems. If there is problem, I like to fix it.

    #8565
    GrilledCheeseStick
    Participant

    I don’t know what it could be. It doesn’t happen in daggerfall. In that game I can click the mouse all I want and it doesn’t send me strafing. Ill test later with the widget and other games.

    #8566
    adminadmin
    Keymaster

    I believe mouse works fine, it just some duke setting, maybe you can describe what you have in setup. I have this:

    Current Controller Type (Keyboard and Mouse)

    In Mouse setup I have :

    Left Button (Fire)
    Middle Button (Mouse_Aiming)
    Right Button (Inventory)

    Middle and Right button actions should be switched probably for physical mouse, I have setup for touchscreen.

    Please check it. In worst case I find somewhere my bluetooth mouse and will test it.

    #8567
    GrilledCheeseStick
    Participant

    I somehow got it working! I did that widget for right mouse and once I clicked that I could then use my mouse no problem. I even restarted a few times without clicking the widget and it was working great. The only time it comes up again is when I use my mouse on the special keys but that’s something easily avoidable. Thanks for spending your time helping me out.

    #8568
    adminadmin
    Keymaster

    You are welcome.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.