How to optimize Master of Magic

This topic contains 4 replies, has 3 voices, and was last updated by  Islander 1 month, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7294

    MilesBeyond
    Participant

    I’m wondering if anyone has been able to get Master of Magic running at a decent pace. The game runs at a snail’s pace, even at 30k+ cycles, and there are a few in-game options that help (disabling all music and sound speeds it up a little), it’s not a big difference.

    This isn’t a problem unique to Magic Dosbox and is an issue on PCs as well, but I’m wondering if anyone’s found any settings that work well for Master of Magic and help the game chug along a bit faster.

    #7295
    Al ex
    Al ex
    Moderator

    I don’t own the game, so sadly, I can’t test. But it’s weird, because according to the Dosbox compatibility page, it should work fine: https://www.dosbox.com/comp_list.php?showID=40&letter=M
    Some speed issues on 15 years old PCs (Athlon XP 1800), but even an entry-level smartphone cpu is much faster than that.

    Have you compared the performance to gameplay videos on Youtube? I’m asking, because maybe the slow gamespeed is just what the developers intended it to be (as annoying as that might be)?

    #7296

    MilesBeyond
    Participant

    Yeah, and this generally isn’t a problem I’ve had in the past. Youtube videos run considerably faster, as does my desktop. My laptop actually runs a bit slower, but that’s a problem with the laptop and apparently one inherent in the model (really low quality fan, so I start to experience slowdown after running anything for half an hour). My phone is a Galaxy A5 which should have no trouble with this, which is why I’m assuming it’s something I’ve done in the settings.

    Right now I’ve got it at 64MB memory, Dynamic CPU, 45K cycles, XMS EMS UMB all checked. It generally starts okay-ish but starts to get bogged down a few dozen turns into the game (which Master of Magic always does but here it’s a lot more dramatic and noticeable than it is on either my desktop or on Youtube videos).

    #7297
    Al ex
    Al ex
    Moderator

    Hm. My initial thought was that maybe your A5 isn’t powerful enough. But Master of Magic only requires a 386SX, and even the 1st gen A5 would be perfectly capable of emulating this.

    But that leads me to another idea: your cycle settings are definitely much too high, and that will cause slowdowns. As soon as the cpu becomes overloaded, emulation starts to lag. Also, constant strain on the cpu will cause heating, and then it will be throttled by cpu management. This is what’s most likely happening when it suddenly slows down a couple of minutes into the game.

    To emulate a 386SX/25 MHz, you only need as little as ~3000-4000 cycles. So I’d suggest you reduce your settings instead of cranking them up ever further. Try something like 6000 for example, or maybe even 10000, then you can also set frameskip=0 to make it look smoother. Also, reduce memory to 4 or 8 MB, to match the system requirement better.

    #7308

    Islander
    Participant

    Does the slowdown occur when entering/exiting the city screen, closing/opening dialogs, etc?

    I solved that problem on Linux by changing to

    output=overlay

    or

    output=surface

    in the config file.

    A Windows user solved it by changing to

    output=ddraw

    instead.

    I haven’t tried Master of Magic on Magic DOSBox yet.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.