Choppy sound in Daggerfall

Viewing 2 posts - 16 through 17 (of 17 total)
  • Author
    Posts
  • #7818
    MastoreMastore
    Participant

    I’m running it completely stock. I’ve other emulators as well (not DOS, though), and it only happens in Magic DosBox… It’s really weird and confusing, I’ve never experienced this before?

    #7820
    Al exAl ex
    Keymaster

    Sound issues are almost always related to cpu overload. Soundblaster/Adlib becomes choppy (starts skipping), while General MIDI/MT32 develops a rubberband effect.

    Things you can try:

    1. Enable expoert settings, set cycles = max 50%
    2. in either Exert settings, use a fixed cycles setting. Something like cycles = 30000 should work fine
    3. disable Expert settings, instead use the “Performance: custom” setting in the profile GUI. Launch your game (will run at 3000 cycles), go poast the intro screen, then gradually increase cycles from the menu (“Power” options, the blue potion icon), until you find a sweet spot.
    4. try another DOS emulator for comparison, to see it’s an issue specifically with Magic Dosbox. There are several free ones around.

Viewing 2 posts - 16 through 17 (of 17 total)
  • You must be logged in to reply to this topic.