Choppy sound in Daggerfall

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #7629
    MastoreMastore
    Participant

    Hi,

    Recently I’ve started experiencing very choppy sound and music while playing Daggerfall, starting even from the startup video. The odd thing is, it seems to only affect Daggerfall and no other game I’ve tried. I’ve tried changing as many settings as possible but it makes no difference. Any idea what the problem could be, and have other people experienced this as well?

    I’m using a Galaxy s10+, am running the latest version of Magic Dosbox, and recently upgraded to Android 10 (maybe this could be it?).

    The extremely choppy sound makes the game pretty much unplayable for me, so any help would be greatly appreciated.

    #7630
    adminadmin
    Keymaster

    Hi, and before update it was allright? Maybe simple device restart can fix it…

    #7632
    MastoreMastore
    Participant

    A restart doesn’t help, unfortunately. Come to think of it, it’s been like this ever since I got this phone back in October. It was fine on my S9+. Unfortunately, my old phone was stolen, so I can’t test it.
    It’s also so weird that it seems to exclusively be an issue in Daggerfall…

    #7633
    Al exAl ex
    Keymaster

    Which S10 variant? I might be able to test on an S10e with Exynos chip, and see if I can reproduce the issue.

    It does sound like a throttling/downclocking issue. You can try to add Magic Dosbox to the games list in Samsung Game Launcher, and set it to performance mode.

    #7634
    MastoreMastore
    Participant

    Exynos s10+. I see no option anymore to add or remove apps to and from the Game Booster/Launcher, but that may just have been moved. It seems to be already added though, since I can adjust game settings. It’s already set to performance mode, so I don’t think that’s the issue. Like I said, it’s only in Daggerfall for some reason… Extremely odd.

    #7635
    Al exAl ex
    Keymaster

    That’s indeed odd. Is yours a Snapdragon or Exynos phone?
    I’ll transfer my Daggerfall install to the S10 and see what happens.

    I guess you already tried different tweaks in expert settings? Like, cycles = max 80%, or prebuffer=20, things like that?

    #7636
    MastoreMastore
    Participant

    Exynos version.

    I haven’t tried that actually, I’ll try it and let you know.

    #7637
    Al exAl ex
    Keymaster

    Holy shit, fixed cycles are a nightmare! 😱
    I do get smooth sound and very good performance with cycles=max, though.

    #7638
    Al exAl ex
    Keymaster

    My settings:

    [dosbox]
    machine=svga_s3
    memsize=32
    vmemsize=8

    [render]
    frameskip=0

    [cpu]
    core=dynamic
    #valid cputypes (Ykhwong SVN):
    # a)auto
    # b)386
    # c)486
    # d)pentium
    # e)386_prefetch
    # f)pentium_mmx
    cputype=auto
    cycles=max

    [mixer]
    blocksize=512
    prebuffer=0
    rate=44100

    [midi]
    mpu401=intelligent
    mididevice=mt32
    mt32.romdir=/storage/emulated/0/MagicBox/MT32ROM
    mt32.thread=off
    mt32.analog=0
    mt32.reverse.stereo=off
    mt32.dac=1
    mt32.reverb.mode=auto
    mt32.reverb.time=5
    mt32.reverb.level=3
    mt32.partials=32

    [speaker]
    pcspeaker=false
    pcrate=11025
    tandy=off
    disney=false

    [sblaster]
    sbtype=sb16
    sbmixer=true
    oplmode=auto
    oplemu=fast
    oplrate=44100

    #7639
    MastoreMastore
    Participant

    It’s so weird. I just tested it in both screen mirroring and DeX, with almost no choppy sound at all, but when I try again on just the phone the sound is choppy again? I just don’t get it…

    #7640
    Al exAl ex
    Keymaster

    Now that is weird. Maybe create a new game profile, and paste the settings I posted above? Forum software wouldn’t allow me to post everything, but I didn’t make any changes to the missing [joystick] and [dos] sections, and you’ll need to configure [autoexec] individually anyway.

    #7641
    MastoreMastore
    Participant

    I’ll give it a try a bit later, and let you know by tomorrow.

    #7642
    adminadmin
    Keymaster

    I experienced similar issues if sound card in config did not match game config..

    #7816
    MastoreMastore
    Participant

    Ok, so I’ve tried all these things and nothing works. Still lots of choppy sound,except now I noticed, after trying several other games just to test, that the sound problem affects every single other game I’ve tried… Is it possible to get an older version to test if the problem is the same there, if only to rule it out?

    #7817
    Al exAl ex
    Keymaster

    Are you running a stock phone? Or do you have root / custom rom / custom kernel?

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.