Benchmark

This topic contains 95 replies, has 21 voices, and was last updated by  Facko 1 month ago.

Viewing 6 posts - 91 through 96 (of 96 total)
  • Author
    Posts
  • #7251
    admin
    admin
    Keymaster

    Hm, diablo 2 worked with normal core, do you have svn core off?

    #7253

    Larrynho
    Participant

    For me , runs in normal core and dont put the CPU type on Pentium, causes freezes and crashes.

    #7254
    Al ex
    Al ex
    Moderator

    I’ve set these two values under [cpu] in expert settings, works best for me:

    cputype=pentium_slow
    isapnpbios=true

    #7256
    Al ex
    Al ex
    Moderator

    You can also try my Diablo 1 profile, it also works for Diablo 2. All you need to do is adjust the mounting in expert settings.

    Diablo (Win95)

    #7258

    Ascended
    Participant

    Thanks guys,
    I tried all your solutions, however still with no luck. Here is what my custom settings are set to. I would love to try someone else is working images. however I don’t think that’s going to happen due to copyright reasons 😖 it’s strange that every other game I install seems to be working ok with no problems. I’d love to see how Diablo 2 works on my Rooted S10+snapdragon……..

    [dosbox]
    memsize=63
    vmemsize=4
    machine=svga_s3

    [render]
    frameskip=2

    [cpu]
    # valid core are: normal, simple, full, auto, dynamic
    # dynamic is the fastest and optimized for the ARM processor + works with Win9x
    core=dynamic
    # new paging methods from MB6 & Ykhwong SVN introduce new cputype settings:
    # valid cputypes are: 386, 486, 386_prefetch (*), 486_prefetch (*), pentium, pentium_mmx
    # (*) = requires normal core setting instead of dynamic
    cputype=pentium_slow
    cycles=auto 20000 100% limit 80000
    cycleup=500
    cycledown=500
    isapnpbios=true

    [sblaster]
    sbtype=sb16
    mixer=true
    oplmode=auto
    oplemu=fast
    oplrate=22050

    [mixer]
    rate=22050
    blocksize=1024
    prebuffer=20

    [dos]
    xms=true
    ems=false
    umb=true
    keyboardlayout=auto

    [ipx]
    ipx=false

    [joystick]
    joysticktype=none
    timed=true

    [midi]
    # Only enable MIDI if you have the necessary MT32 ROM files
    mpu401=none
    mididevice=none

    [speaker]
    pcspeaker=false
    tandyrate=22050
    tandy=auto
    pcrate=8000
    disney=false

    [gus]
    gus=false

    [autoexec]
    @Echo Off
    imgmount c /storage/CACD-6248/Dosbox/win95/Win95.img -t hdd -fs fat -size 512,63,64,1023
    imgmount d /storage/CACD-6248/Dosbox/win95/HDD_Diablo2.img -t hdd -fs fat -size 512,63,64,1023
    boot -l c

    #7259

    Facko
    Participant

    I noticed you said you installed the diablo 2 expansion. Diablo 2 only seems to run 1.05 or lower. Think it’s a direct x issue. You would need windows xp to run the expansion (1.07 is the lowest xpac version). So you can only run vanilla diablo 2 in MDB.

Viewing 6 posts - 91 through 96 (of 96 total)

You must be logged in to reply to this topic.